Problem with openapi3_parser gem

's Avatar


25 Oct, 2019 07:30 PM


I've been having some problems displaying the documentation for a gem I've authored.

Looking up documentation for the gem and different versions seems to show it stuck in processing. Examples:

Incidentally I get a 503 for

Then for the Github documentation. I tried to update this to use a GitHub webhook and that seemed to erase the old documentation e.g:

When I try to "add project" I get ERROR response for git://

My GitHub configuration is a push webhook with the following options:

Payload URL:
Content type: application/json
Enable SSL

And I can see when returned "OK" from the last hook call.

I've tried to build the docs locally to see if that showed any signs of a problem and that was ok:

➜  openapi3_parser git:(master) yard doc
Files:         112
Modules:        12 (   10 undocumented)
Classes:       126 (   70 undocumented)
Constants:      10 (    7 undocumented)
Attributes:     45 (    0 undocumented)
Methods:       491 (  135 undocumented)
 67.54% documented

Any steps I can take next to work this out would be great,


  1. Support Staff 1 Posted by lsegal on 26 Oct, 2019 07:27 PM

    lsegal's Avatar

    We fixed a few things on our end and this seems to be working now-- let me know if you still see any issues with the gem!

  2. 2 Posted by kevindew on 27 Oct, 2019 09:50 AM

    kevindew's Avatar

    Great - that seems to have resolved everything.

    Thank you.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac