README, etc. for "onstomp" gem raising an error

ian.eccles's Avatar


05 Apr, 2011 06:00 PM

When visiting the docs for onstomp ( an error is generated by the README page. The Class / Method browsers appear to work, and those pages do not seem to generate any errors.

However, all other included pages (LICENSE, UserNarrative, etc) produce the same error page as README.

I'm the author of the gem, so if this is a result of something I'm doing (parameters in my .yardopts file, etc) let me know and I'll do what I can to correct any problems on my end.

Have a good day.

  1. Support Staff 1 Posted by lsegal on 05 Apr, 2011 06:04 PM

    lsegal's Avatar

    Have you tried running YARD locally to generate the project? If so, does it work?

  2. 2 Posted by ian.eccles on 05 Apr, 2011 06:06 PM

    ian.eccles's Avatar

    Yeah, I do a local build and use github pages to host the docs at:

    I've used with other gems without giving any problems, but this is the first time I've added a .yardopts file to a gem.

  3. Support Staff 3 Posted by lsegal on 05 Apr, 2011 06:16 PM

    lsegal's Avatar

    For some reason it seems to be working just fine right now-- can you confirm? It might have just been a temporary hiccup.

  4. 4 Posted by ian.eccles on 05 Apr, 2011 06:19 PM

    ian.eccles's Avatar

    Yeah, I just brought up the README page just fine, thanks. I just started digging deeper into YARD, writing custom handlers and such, so I just assumed I broke something.

    Thanks for your time.

  5. Support Staff 5 Posted by lsegal on 05 Apr, 2011 06:21 PM

    lsegal's Avatar

    Great, glad to hear it's working!

  6. lsegal closed this discussion on 05 Apr, 2011 06:21 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac