Ruby Doc is not generated

's Avatar


04 Apr, 2014 09:45 PM

What happened? YARD generateds and displayes documentation locally fine. This is just a test gem to learn Ruby and GEM

Error message:Even after almost 24 hours
We Couldn't Find That Gem

We can't seem to find any versions for the gem goest. Are you sure you typed it correctly?

You can also see a list of available RubyGems here.

  1. Support Staff 1 Posted by lsegal on 04 Apr, 2014 10:23 PM

    lsegal's Avatar

    Should be fixed now.

  2. lsegal closed this discussion on 04 Apr, 2014 10:23 PM.

  3. thomas re-opened this discussion on 07 Apr, 2014 08:35 PM

  4. 2 Posted by thomas on 07 Apr, 2014 08:35 PM

    thomas's Avatar

    Thank you for your quick response. I was able to see the documentation on Rubydoc.
    What was the issue? I tried to push a new version ..this time with README.rdoc and and LICENSE.txt file. Tried to go to Rubydoc and I get the same message
    "Oops, We Couldn't Find That Gem"

    Not sure if having to README files may cause issue? Which one will be picked up by YARD for generating the documentation?

    May be I will just wait and see what happens. I want to see if the README file will show up which I think will server as release notes.


  5. Support Staff 3 Posted by lsegal on 08 Apr, 2014 04:26 AM

    lsegal's Avatar

    The gem is still working for me. We were having issues with server restarts, but that cleared up over the weekend.

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:


Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac