Problem with branches or repo config

's Avatar

ben

09 Oct, 2019 10:21 PM

We're having an unusual problem with our rubydocs for our library recurly-client-ruby:

https://www.rubydoc.info/find/github?q=recurly-client-ruby

I'm noticing there is a message "no master fork"

What is there also appears to not be respecting our .yardopts file: https://github.com/recurly/recurly-client-ruby/blob/master/.yardopts

We do have a webhook setup which appears to be working.

Everything was working fine until recently. Is there any work you can do on your end to clean it up?

  1. Support Staff 1 Posted by lsegal on 09 Oct, 2019 10:37 PM

    lsegal's Avatar

    Fixed on our end thanks for reporting this!

  2. Support Staff 2 Posted by lsegal on 09 Oct, 2019 10:38 PM

    lsegal's Avatar

    NB: There may be some search caching still in play, but if you visit via the index or search another query you should see the correct result.

  3. 3 Posted by Ben on 09 Oct, 2019 10:54 PM

    Ben's Avatar

    Thanks for the quick response!

    The search results no longer showing "no master branch" when i search a new term:
    https://www.rubydoc.info/find/github?q=recurl

    I am curious about how I can get it to respect your `.yardopts` though. We have a file GETTING_STARTED.md in the root of the project and our opts specify `--readme GETTING_STARTED.md`

    Is this correct? It works locally but does not seem pick it up in rubydocs: https://www.rubydoc.info/github/recurly/recurly-client-ruby

  4. Support Staff 4 Posted by lsegal on 09 Oct, 2019 11:05 PM

    lsegal's Avatar

    You should be able to resolve this with:

    --readme GETTING_STARTED.md
    - GETTING_STARTED.md
    

    The readme switch is a bit of an old one and there might be a bug on rubydoc.info not respecting it. If you mark the file as an "extra file" (any files listed after the -) it should keep the file around to serve it. You can see an example of this in https://github.com/lsegal/yard/blob/master/.yardopts

  5. 5 Posted by Ben on 09 Oct, 2019 11:21 PM

    Ben's Avatar

    Interesting, but makes sense. I did try that but I'm still not seeing results: https://github.com/recurly/recurly-client-ruby/commit/a785d9da42b6a8da0dc7cee03487322905ef996a

    It does continue to work locally though. I'm running yard 0.9.20 locally

  6. 6 Posted by Ben on 09 Oct, 2019 11:26 PM

    Ben's Avatar

    I noticed in this thread: https://rubydoc.tenderapp.com/discussions/problems/654-wrong-transl...

    you said

    Yes, the .yardopts must be packaged with the gem for rubydoc to pick it up for gem docs hosting.
    

    Could that be the issue? Do i need to add that to my gemspec?

  7. 7 Posted by Ben on 09 Oct, 2019 11:29 PM

    Ben's Avatar

    the .yardopts file does appear to be in the resulting gem after running gem build recurly.gemspec

  8. 8 Posted by Ben on 10 Oct, 2019 03:13 AM

    Ben's Avatar

    This is pretty strange, but I moved everything back to the README for now and removed the yardopts. and the README is still not showing up: https://www.rubydoc.info/github/recurly/recurly-client-ruby/

  9. 9 Posted by Ben on 10 Oct, 2019 05:54 PM

    Ben's Avatar

    Kind of seems like the "No master fork" error is back too

  10. Support Staff 10 Posted by lsegal on 10 Oct, 2019 08:37 PM

    lsegal's Avatar

    So it looks like a couple of other projects have been dealing with this same issue. Still working on diagnosing the root issue but I've temporarily unblocked your project and you should now be seeing the README along with correct master fork info. This means that you should be able to apply your .yardopts settings to get the other extra files displaying.

    The problem may come back over the next day or two but rest assured we're investigating. I will keep this open and close when we've identified the root issue and are sure that this won't come back.

    Thanks again for reporting the issue!

  11. 11 Posted by Ben on 10 Oct, 2019 09:35 PM

    Ben's Avatar

    Thanks! I'd love to move this getting started stuff back out of the main README though. It uses yard syntax so is kind of confusing when viewed from GitHub. Should I try to do that again, or should I wait? do you think the problem was with my library in particular or with some larger issue with yardopts?

  12. Support Staff 12 Posted by lsegal on 10 Oct, 2019 10:04 PM

    lsegal's Avatar

    You should be able to give it another shot and see what happens right now. The issue was with a larger problem in the rubydoc.info deployment pipeline.

  13. 13 Posted by Ben on 10 Oct, 2019 10:25 PM

    Ben's Avatar

    It appears to be working now! The yardopts file is being respected: https://www.rubydoc.info/github/recurly/recurly-client-ruby/

  14. 14 Posted by Ben on 30 Oct, 2019 10:28 PM

    Ben's Avatar

    Sorry to be a bother, but it's reverted back to the broken state: https://www.rubydoc.info/github/recurly/recurly-client-ruby/

Reply to this discussion

Internal reply

Formatting help / Preview (switch to plain text) No formatting (switch to Markdown)

Attaching KB article:

»

Attached Files

You can attach files up to 10MB

If you don't have an account yet, we need to confirm you're human and not a machine trying to post spam.

Keyboard shortcuts

Generic

? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac