GitHub project's docs return a 404 after forced update

Jimmy's Avatar


30 Dec, 2010 09:23 PM

I just pushed a commit that I amended a couple times with a forced push to my GitHub repository, and now my docs on are returning a 404. I tried to refresh the docs, but it just hangs forever with the refresh icon spinning. Then I tried adding the project again with the "add project" popover form but I get "Invalid git repository or URL" even when specifying "master" as the commit. How can I recover from this? Thank you!

  1. 1 Posted by Jimmy on 30 Dec, 2010 09:24 PM

    Jimmy's Avatar
  2. Support Staff 2 Posted by lsegal on 30 Dec, 2010 09:31 PM

    lsegal's Avatar

    I've reset your project, so it should work now.

    You probably already know (have heard) that forced pushes are bad when other people (or entities in this case) are tracking your repo. This is why :)

  3. lsegal closed this discussion on 30 Dec, 2010 09:31 PM.

  4. Jimmy re-opened this discussion on 30 Dec, 2010 09:48 PM

  5. 3 Posted by Jimmy on 30 Dec, 2010 09:48 PM

    Jimmy's Avatar

    Thank you. It seems to be loading an older version of the docs still, however. Note that it's still using the version with blockquotes which have been replaced with pre/code tags, per our discussion on that YARD issue earlier. I clicked the reload button but it still showed the old docs. I never do forced pushes unless I'm just amending a commit and it's been like 10 seconds or less, when it's very unlikely anyone has pulled the original commit. Now I see how even that won't work if automated systems are watching the repository. I will avoid them entirely now. Sorry about this.

  6. 4 Posted by Jimmy on 30 Dec, 2010 09:50 PM

    Jimmy's Avatar

    Ugh, ignore me again. Looks like it was just browser cache.

  7. nap closed this discussion on 03 Jan, 2011 03:41 PM.

Comments are currently closed for this discussion. You can start a new one.

Keyboard shortcuts


? Show this help
ESC Blurs the current field

Comment Form

r Focus the comment reply box
^ + ↩ Submit the comment

You can use Command ⌘ instead of Control ^ on Mac